Lamobo Openwrt image

OpenWrt firmware for BPI-R1 is updated, it support by Lamobo.

This firmware is built based on the OpenWrt master branch r42830.

Q&A

  • I am a new BPI-R1 user, how to use this firmware?

    1. For a new user, we recommend to use the ready configured firmware. please download it from forum download page: http://elastos.org/elorg_common/Lamobo-R1/2015-01-12/openwrt-sunxi-Lamobo-R1-sdcard-vfat-ext4.img
    2. BPI-R1 accepts TF-card. Make sure your TF-card is bigger than 512MB. Using below command to generate a bootable TD-card: $ sudo dd if=openwrt-sunxi-BPI-R1-sdcard-vfat-ext4-configured.img of=/dev/sdX bs=1MB

    3. Notes for the ready configured firmware:

  • If I want to use the original firmware, what can I do?

    1. The original firmware is built directly from source code. It almost does not install software, except OpenWrt base software. Please download it from:elastos.org/elorg_common/Lamobo-R1/2015-...sdcard-vfat-ext4.img.
    2. Prepare a TTL thread for to connent OpenWrt bash terminal.
    3. Connect to OpenWrt terminal throught TTL thread, modify OpenWrt packages source. All Of OpenWrt packages is released on:

      elastos.org/elorg_common/Lamobo-R1/2014-01-12/packages. You can change opkg.conf(/etc/opkgopkg.conf) content to below:
      src/gz chaos_calmer_base http://elastos.org/elorg_common/Lamobo-R1/2014-01-12/packages/base
      src/gz chaos_calmer_luci http://elastos.org/elorg_common/Lamobo-R1/2014-01-12/packages/luci
      src/gz chaos_calmer_management http://elastos.org/elorg_common/Lamobo-R1/2014-01-12/packages/management
      src/gz chaos_calmer_packages http://elastos.org/elorg_common/Lamobo-R1/2014-01-12/packages/packages
      src/gz chaos_calmer_routing http://elastos.org/elorg_common/Lamobo-R1/2014-01-12/packages/routing
      src/gz chaos_calmer_telephony http://elastos.org/elorg_common/Lamobo-R1/2014-01-12/packages/telephony
      

      And then, update opkg database: $ opkg update

    4. Install OpenWrt packages. The below packages are needed:

      $ opkg install kmod-b53
      $ opkg install kmod-rtl*
      $ opkg install hostapd
      $ opkg install wpa-supplicant
      $ opkg install luci-proto-ppp
      $ opkg install ppp-mod-pptp
      $ opkg install luci
      $ opkg install luci-theme-bootstrap
      

      Full package list please refer: kingone.elastos.org/2015/01/13/lamobo-r1-package-list/

    5. Modify the network config.Append below text to “/etc/config/network”:

config switch ‘eth0′
option enable ’1′
option enable_vlan ’1′
option reset ’1′

config interface ‘lan’
option proto ‘static’
option ipaddr ’10.0.1.1′
option netmask ’255.255.255.0′
option defaultroute ’0′
option peerdns ’0′
option nat ’1′
option ifname ‘eth0.1′
option type ‘bridge’

config switch_vlan
option device ‘eth0′
option ports ’0 1 2 4 8t’
option vlan ’1′

config interface ‘wan’
option ifname ‘eth0.2′
option proto ‘dhcp’

config switch_vlan
option device ‘eth0′
option vlan ’2′
option ports ’3 8t’

start router web server:

$ /etc/init.d/uhttpd start
$ /etc/init.d/uhttpd enable

That’s all. Good luck!

forum discuss link:

http://www.bananapi.com/index.php/forum/general/417-banana-pi-bpi-r1-openwrt-image-2-0-release-note#1229

Wiki link:

http://wiki.geiges.net/doku.php?id=openwrt_bpi-r1

results matching ""

    No results matching ""